您好,欢迎光临系统之家!

系统之家 - 为您打造全网最优秀的系统论坛!

 找回密码
 注册
搜索

编译报错version `GLIBC_2.27' not found的解决

查看: 69|回复: 0

[讨论] 编译报错version `GLIBC_2.27' not found的解决 [复制链接]

Rank: 64Rank: 64Rank: 64Rank: 64

UID
5
帖子
6499
威望
4261 点
黄金
10430 金币
在线时间
4390 小时
注册时间
2005-5-13
最后登录
2019-12-8

终身成就奖 宣传大使奖

发表于 2019-8-10 21:31:40 |显示全部楼层
我是编译Pandora SDK时遇到了这个报错。
不同的发行版,libc.so.6的位置是不同的。ubuntu的libc在/lib/x86_64-linux-gnu/libc.so.6
可以用以下命令查看版本:
  1. strings /lib/x86_64-linux-gnu/libc.so.6 |grep GLIBC
复制代码
我看了眼我的ubuntu14带的是glibc 2.19,本以为那装个deb包升级一下就ok了,结果找了个版本一安装,好多东西都崩溃了,甚至连桌面都崩溃。难倒是我的姿势不太对?
一合计别费劲了,重装ubuntu18一看,glibc正好是2.27。问题解决,=。=b



郑重声明:
1. 本人过去、现在以及将来都不认识楼主,且自古以来与楼主无利益关系。
楼主表述之事与本人无关,只是本着"看贴回贴,利人利己的中华民族优秀传统美德",顺便凑个热闹.
2. 本人在此留言均为网络上复制,用于检验电脑键盘录入、屏幕显示的机械、光电性能。
并不代表本人局部或全部同意、支持或者反对楼主观点。

使用道具 举报

发表回复

您需要登录后才可以回帖 登录 | 注册

回顶部